Loosen up t.c.pants constraints.

Review Request #712 — Created July 21, 2014 and submitted — Latest diff uploaded

jsirois
commons
jsirois/pants/flexible_dep_constraints
312
pants-reviews
areitz, stuhood
commit 705a0c960c348a2c911edb60f424a07bc843e601
Author: John Sirois <jsirois@twitter.com>
Date:   Mon Jul 21 22:05:55 2014 -0600

    Loosen up t.c.pants constraints.
    
    The twitter.common.pants plugins were pinned hard to
    pantsbuild.pants==0.0.17 limiting the context they could be used in.
    
    Expand the scope of supported pants releases up to 0.1.0 even though
    this is likely to permissive.  The pantsbuild.pants distributions will
    probably continue to break various APIs until we hit 0.1.0 and being
    more permissive and then fixing the low bound on the range when the
    plugins break seems about the best we can do.
    
    This also preps an sdist release with a version bump.

 pants-plugins/3rdparty/BUILD                        | 2 +-
 pants-plugins/src/python/twitter/common/pants/BUILD | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
I tried this locally on a pantsbuild.pants==0.0.18 (aka recent OSS pants master) + twitter.common.pants==0.3.2 release that was failing due to a dep conflict and using twitter.common.pants==0.3.3 the conflict is fixed.
Loading...