Correctly add requirements of included dependencies that provide distributions.

Review Request #566 — Created June 18, 2014 and submitted

wickman
pants
pants-reviews
jsirois
Correctly add requirements of included dependencies that provide distributions.
When we upgraded from twitter.pants to pantsbuild.pants, setup_py broke for us in that not all source distributions had the correct set of install_requires dependencies.  This elif clause was in the original setup_py so I'm not sure why it was removed.
JS
  1. Ship It!
  2. 
      
IT
  1. Ship It!
  2. 
      
WI
WI
  1. Looks like I don't have push access to pantsbuild/pants.  Could a committer push this?  Thanks!
    1. Patrick submitted this @ https://github.com/pantsbuild/pants/commit/b2f4a71c6052fdffb74c096064af7f7ea9af9edd
      Please mark this review submitted.
  2. 
      
WI
Review request changed

Status: Closed (submitted)

Loading...