Rename PARALLEL_BOTH to PARALLEL_CLASSES_AND_METHODS inside JUnit Runner
Review Request #3962 - Created June 1, 2016 and submitted
|benjyw, gmalmquist, stuhood|
Feedback in https://rbcommons.com/s/twitter/r/3925/ was to rename PARALLEL_BOTH to prevent confusion if we were to add more concurrency options in the future.
This just changes the junit-runner java code so that we can publish a new jar and make the corresponding updates in pants python code.
CI green at https://travis-ci.org/pantsbuild/pants/builds/134416147