Add public api markers for pantsd and options

Review Request #3484 - Created Feb. 19, 2016 and submitted

Information
Matt Olsen
pants
2710, 2942
Reviewers
pants-reviews
benjyw, gmalmquist, jsirois, kwlzn, stuhood, zundel

Add public api markers for pantsd and options

The following modules were reviewed and all api's were left as private. As
far as I can tell these modules are not currently used by pluggins.

  • pants.option.arg_splitter
  • pants.option.errors
  • pants.pantsd.fs_event_service
  • pants.option.global_options
  • pants.option.option_tracker
  • pants.option.option_util
  • pants.option.option_value_container
  • pants.option.optionable
  • pants.option.options_bootstrapper
  • pants.pantsd.pailgun_server
  • pants.pantsd.service.pailgun_service
  • pants.pantsd.subsystem.pants_daemon_launcher
  • pants.option.parser
  • pants.option.parser_hierarchy
  • pants.option.ranked_value
  • pants.option.scope
  • pants.pantsd.watchman
  • pants.pantsd.watchman_client

CI green: https://travis-ci.org/pantsbuild/pants/builds/111022208

Issues

  • 0
  • 3
  • 0
  • 3
Description From Last Updated
Matt Olsen
Yi Cheng
Benjy Weinberger
Matt Olsen
Benjy Weinberger
Eric Ayers
Benjy Weinberger
Matt Olsen
Nick Howard (Twitter)
Matt Olsen
Review request changed

Status: Closed (submitted)

Change Summary:

commit e974c56163989a0ccf206e20357f264723e6d868

Loading...