Remove deprecated `[compile.java]` options.

Review Request #2678 - Created Aug. 21, 2015 and submitted

Information
John Sirois
pants
jsirois/java_compile/deprecation_cleanup
2042
2682, 2680
dea9f28...
Reviewers
pants-reviews
gmalmquist, zundel

Kill [compile.java] source and target options in favor of
[jvm-platform] options.

What was:

[compile.java]
source: 7
target: 7

Should now be:

[jvm-platform]
platforms: {
    'java7': {
      'source': 7
      'target': 7
    },
  }
default_platform: java7

src/python/pants/backend/jvm/tasks/jvm_compile/java/java_compile.py | 19 +++----------------
1 file changed, 3 insertions(+), 16 deletions(-)

CI went red here:
  https://travis-ci.org/pantsbuild/pants/builds/76664815

Issues

  • 0
  • 1
  • 0
  • 1
Description From Last Updated
John Sirois
Eric Ayers
John Sirois
John Sirois
John Sirois
Review request changed

Status: Closed (submitted)

Nick Howard (Twitter)

   

You might want to update these errors as well since they suggest using the option that was removed.

  1. Good catch.  I'll follow up with that after the release - still scrambling to get one more small change up for RB and included in the release.
  2. https://rbcommons.com/s/twitter/r/2682/
Loading...