Upgrade pantsbuild/pants to apache thrift 0.9.2.

Review Request #2484 - Created July 14, 2015 and submitted

Information
John Sirois
pants
jsirois/upgrade_default_thrift
1817, 1818
eec3573...
Reviewers
pants-reviews
benjyw, stuhood, zundel
Since the pantsbuild/pants repo does not exercise the customized finagle
bindings of thrift-0.5.0-finagle, upgrade to 0.9.2 and simplify.

As an added benefit, 0.9.2 python gen almost supports python3 - a feature
Clover Health is after (seems to fully support after 2to3 is run over
generated code).

 3rdparty/BUILD                                              | 57 +++++---------------------------------------------
 pants.ini                                                   | 32 ++--------------------------
 src/python/pants/backend/codegen/tasks/apache_thrift_gen.py |  2 +-
 3 files changed, 8 insertions(+), 83 deletions(-)
CI went green here:
  https://travis-ci.org/pantsbuild/pants/builds/71015681
John Sirois
John Sirois
John Sirois
Eric Ayers
Stu Hood
John Sirois
John Sirois
Review request changed

Status: Closed (submitted)

Loading...