Rid pantsbuild.pants of an un-needed antlr dep.

Review Request #1989 - Created March 25, 2015 and submitted

Information
John Sirois
pants
jsirois/antlr/kill_unneeded_dep
1328
1afbfaa...
Reviewers
pants-reviews
dturner-tw, lahosken, patricklaw, zundel
The dep is only needed by 1 test that attempts to use the generated code
to parse via the antlr runtime.  This change lifts the dep from the
requirements.txt file used to bootstrap pants into a stand-alone
python_requirement_library that the test can depend on without forcing
each pants bootstrap to fetch this dep.

Since 3rdparty/python/BUILD was used for an include in the docs, doc gen
broke leading to fixes for CI doc gen errors.

 3rdparty/python/BUILD                      | 9 ++++++++-
 3rdparty/python/requirements.txt           | 5 -----
 build-support/bin/release.sh               | 6 +-----
 examples/src/python/example/3rdparty_py.md | 2 +-
 src/python/pants/CHANGELOG.rst             | 6 +++---
 src/python/pants/backend/python/BUILD      | 1 -
 testprojects/src/python/antlr/BUILD        | 1 -
 7 files changed, 13 insertions(+), 17 deletions(-)

Ran ./build-support/bin/ci.sh green locally.

CI went green here:
https://travis-ci.org/pantsbuild/pants/builds/55880777

Issues

  • 0
  • 0
  • 1
  • 1
Description From Last Updated
Patrick Lawson
John Sirois
John Sirois
John Sirois
Review request changed

Status: Closed (submitted)

David Turner
Ship It!
Eric Ayers
Ship It!
Loading...