Prepare for an 0.8.2 release of twitter.common.pants

Review Request #1967 — Created March 21, 2015 and submitted

stuhood
commons
pants-reviews
dturner-tw, ity, jsirois, Yasumoto
Prepare for an 0.8.2 release of twitter.common.pants

$ ./pants setup-py pants-plugins/src/python/twitter/common/pants:plugins
INFO] Detected git repository at /Users/stuhood/src/commons on branch stuhood/prepare-for-0.8.2-release

17:08:41 00:00 [main]
(To run a reporting server: ./pants server)
17:08:41 00:00 [bootstrap]
17:08:41 00:00 [setup]
17:08:41 00:00 [parse]
Executing tasks in goals: setup-py
17:08:41 00:00 [setup-py]
17:08:41 00:00 [setup-py]
Running packager against /Users/stuhood/src/commons/dist/twitter.common.pants-0.8.2
Writing /Users/stuhood/src/commons/dist/twitter.common.pants-0.8.2.tar.gz
SUCCESS

IT
  1. Ship It!
  2. 
      
ST
Review request changed

Status: Closed (submitted)

TE
  1. Ship It!
  2. 
      
DT
  1. Ship It!
  2. 
      
JS
  1. 
      
  2. There was no update / no api changes.  Was this to work around explit dep conflicts with pantsbuild.pants versions?
    1. Yes.

    2. OK - when I crack open the sdist, I find:
      ```
          'install_requires': [   'pantsbuild.pants>=0.0.28,<0.1.0',
                                  'twitter.common.contextutil==0.3.3'],
      ```
      
      So the conflict must have been on the contextutil hard dep and not pantsbuild.pants.  If your can confirm this, the right fix may be to loosen the t.c.contextutil dep.  It make sense to me to have the plugin have all strict requirements or all ranged, but the mix is odd and will continue to cause ~fake publishes to be needed.
  3. 
      
Loading...