Upgrade pants to 0.0.29

Review Request #1909 — Created March 12, 2015 and submitted

jsirois
commons
jsirois/pants/upgrade
360, 361
70ffbe4...
pants-reviews
ity, jinfeng, Yasumoto
The scrooge plugin is now in contrib, so add this to the pants script
deps and the list of non-core plugin backends.

Also migrate pants.ini config changes and CLI flags, fixup BUILD
deprecations and upgrade some tool deps.

 .travis.yml                          |  4 ++--
 3rdparty/jvm/org/apache/lucene/BUILD |  2 +-
 BUILD.tools                          | 10 ++++------
 build-support/bin/ci.sh              | 12 ++++--------
 pants                                | 10 +++++++++-
 pants.ini                            | 30 +++++++++---------------------
 6 files changed, 29 insertions(+), 39 deletions(-)
CI went green here:
  https://travis-ci.org/twitter/commons/builds/54198312
JS
JS
JS
IT
  1. thanks for doing this John! Now that I am aware, will do from next time.

  2. 
      
JS
  1. Thanks Ity - submitted @ https://github.com/twitter/commons/commit/24fab7216404a12a85ab6cc8af72c59bd181ac99
  2. 
      
JS
Review request changed

Status: Closed (submitted)

Loading...