Rename the few remaining "jvm_args" variables to "jvm_options".
Review Request #1631 - Created Jan. 20, 2015 and submitted
also fixes some related stale comments. Note: doesn't change the names of the few remaining jvm_args config keys, that will happen later. This change is just about reducing naming confusion in the code.
CI passes: https://travis-ci.org/pantsbuild/pants/builds/47689466.
looks good modulo a few comments that need updating.
Address code review comments.
Revision 2 (+28 -37)
Status: Closed (submitted)
Submitted as 62b6645e3384a5a36454f74513dd36171cb1be1a.