update and narrow down our "setting up Pants is hard" message

Review Request #1007 — Created Sept. 9, 2014 and submitted

lahosken
pants
369b247...
pants-reviews
patricklaw, stuhood

pantsbuild.pants is is a thing. So stop saying it's not installable.

We had commented out stuff about how to install it. Un-comment it.

For a venv-y example, see twitter/commons; not pants' repo, that was only true for a brief time.

BUT, setting up Pants in your code workspace still requires a PhD in Pants-ology. So shift our scary warning over to the setup_repo page.



LA
ZU
  1. 
      
  2. src/python/pants/docs/install.rst (Diff revision 1)
     
     

    for a quick start, you just need to copy a few other files from the pantsbuild/pants repo into your repo:

    BUILD.tools
    3rdparty/BUILD
    pants.ini

    1. 3rdparty/BUILD

      I bet you also want 3rdparty/python/BUILD, 3rdparty/python/requirements.txt. And... maybe other things?

      I think we're still figuring out The Set of Files to Copy Over. I'd be happy to hear I'm wrong, though.

    2. I think you are right. I have those files too

  3. 
      
ST
  1. 
      
  2. src/python/pants/docs/install.rst (Diff revision 1)
     
     

    This wasn't really shifted, so much as duplicated. Intentional?

  3. src/python/pants/docs/install.rst (Diff revision 1)
     
     

    this this

  4. 
      
LA
LA
Review request changed

Status: Closed (submitted)

PA
  1. Sorry for the late review--lgtm!

  2. 
      
Loading...